Dead k20!?!


waggie

ek9 type r k20 jrsc
Joined
Feb 15, 2008
Messages
148
just been drivin my ek9 with k20 swap and jrsc,booted it through the gears,7-7500 rpm in 5th then really nasty "burb" sound,lots of grey/white smoke outta exhaust,loss of power,engine stopped and a shed loada oil spurted outta crank case breather!!! :(
any ideas whats happened?this happened to any one?what may have coursed it?
any help will be awesome thanks matt
 


ijwhiteman

Super Moderator
Staff member
Donator
Joined
Jan 29, 2008
Messages
6,259
I think she may have gone bang!

Maybe oil starvation?

Overheated?
 




jason100

HLife
Joined
Jan 7, 2008
Messages
431
Superchargers generate a lot of heat. What rad you running? Maybe you've fryed your head gasket??

Best of luck, sounds expensive whatever has happened
 



jordan101

Active Member
Joined
Feb 25, 2010
Messages
6,028
i am putting my money on head gasket mate unfortunately :(

as said depends if u have upgrade everything when doing the swap and adding the jrsc as if u havent this will have caused a lot of problems
 


689R

gentleman of hyper
Joined
Feb 29, 2008
Messages
2,933
To be fair a JRSC K20 is normally pretty reliable. Just sounds unlucky whats happened to you.
 



waggie

ek9 type r k20 jrsc
Joined
Feb 15, 2008
Messages
148
was at cpl last week for a full day,did 75+ runs and everything was spot on,no problems at all,since then its only done 200-250 miles,was a bit coughy/spluttery on half throttle but i put that down havin to put normal fuel in apposed to 99 oct.am running uprated rad with front mounted fan,won't have thought i was over heating was only out for half hour drive and 90% was just cruisin.
 


Rory

New Member
Joined
Mar 21, 2010
Messages
48
Well it sounds like you will have to whip the head off, as it sounds like you have either piston or ring damage.
Can almost be 99% on it being one or the other.
 


Top