Matt's K20 CW EK9


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
Track beasts popping up everywhere!
 



jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
Too right they are!
You on the 15:40 session with the rest of us?
Clamming for more tracktime now lol
 


DBMatt

K20 EK9 - VTEC Addict
Joined
Feb 7, 2013
Messages
661
Too right they are!
You on the 15:40 session with the rest of us?
Clamming for more tracktime now lol
I am providing I get the car running right :D kind of broke it at oulton hahah. Yeah man I bought more at trax
 


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
Welcome to my world lol
I'll have like 400miles on the engine by the time I hit the track!
Hopefully there's a session available alittle sooner. Like lunchtime.
 


DBMatt

K20 EK9 - VTEC Addict
Joined
Feb 7, 2013
Messages
661
Welcome to my world lol
I'll have like 400miles on the engine by the time I hit the track!
Hopefully there's a session available alittle sooner. Like lunchtime.
Mines an IACV playing up. Going to take it off, blank it and adjust the idle screw. Should be reet! Haha.

Sweet! Yeah nice time that. My sessions at trax were 10:40 and 15:00 I think.
 


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
My iacv is playing up too! Just hunts on idle while it's cold is all.
 



jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
Had a similar issue with my brothers ep3.
We had a spare that was also broken but for a different reason. Built one working one out of the two.
If you bring the IACV to japfest i might be able to tell you what's broken on it. Not that I could fix it then and there though.
 


DBMatt

K20 EK9 - VTEC Addict
Joined
Feb 7, 2013
Messages
661
Had a similar issue with my brothers ep3.
We had a spare that was also broken but for a different reason. Built one working one out of the two.
If you bring the IACV to japfest i might be able to tell you what's broken on it. Not that I could fix it then and there though.
Sweet I'll bring it.

I suspect it might be a broken wire tbh but need to test them with multimeter!
 


jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
On my brothers one had a broken motor and the other must have had a tiny bend in a shaft that runs through it as it was catching the inside of the housing ever so slightly and holding the iacv open.
 


Vtec6000

Super Moderator
Staff member
Donator
Joined
Jun 5, 2007
Messages
6,223
I would definitely check the wires on IACV plug, Ive seen the wires to break several times on those
 





jesse888

Ek9+Turbo+Nurburgring= Heaven
Staff member
Donator
Joined
Oct 16, 2012
Messages
8,927
If in doubt, delete it.
Unfortunately can't do that with oil pumps.
 


DBMatt

K20 EK9 - VTEC Addict
Joined
Feb 7, 2013
Messages
661
If in doubt, delete it.
Unfortunately can't do that with oil pumps.
Haha pretty much! Still a little rough because ECU throwing an error out but drives fine! Might buy a blanking plate and map out the iacv altogether tbh. Don't even need one really, only time my idle would change is when cold, lights on or fan on... Which isn't that much. I don't run power steering or aircon so..

Yeah shame that! Wouldn't think the engine would need an oil pump tbh lol
 


DBMatt

K20 EK9 - VTEC Addict
Joined
Feb 7, 2013
Messages
661
Probably about time I posted something for the first time in almost 3 years! :dance: It certainly has been a while and as you can imagine A LOT has happened!

In summary - when I last posted on August 15th 2015 I was SO stoked with my new K20 and everything it had to offer. From then on, things went on a downward spiral. One day out driving enjoying the sunshine, next thing smoke bellowing out the back of the car; oil pressure light comes on and I pull over switching it off ASAP. Turns out oil cooler hose had come loose and actually spun into the exhaust manifold melting the rubber hose (K series manifold is at the rear next to oil filter), dumping the majority of the oil all over the engine bay, roasting exhaust manifold (causing a fire) and the road behind me :angry2:. Got towed home, filled up with oil, removed oil cooler completely, carried on with life.

The '9 was my only car to this point but after installing the fixed seats & harnesses this became tiresome. My decision to buy a daily driver was drastically accelerated when on the eve of September 16th 2015 disaster struck. Driving home from work, I accelerated away from traffic lights wide open throttle, up to about 3rd gear and suddenly BANG, followed by lots of clunking, a horrible whirring sound & total loss of power. Pulled over at the side of the road and to my horror, smoke bellowing out of the engine bay AGAIN! This time though, it was totally shagged. I could just tell from the way it let go at about 7000rpm. My K-swap was 3 months old, I was devastated.







After various tests & observations, it was clear that cylinder 1 had let go blowing a hole in the back of the block. I could only conclude that this failure was attributed to by the oil cooler hose incident and running pretty much dry on oil for a short period until I registered what was occurring.

Following this, I purchased my daily driver 2 days later - Ford Fiesta 1.0 Ecoboost, cracking little motor!





The '9 then spent almost an entire year sat on my driveway in disgrace, I totally fell out of love with it & set about eventually getting another K20 for it. I finally bought another K20 in May 2016 and set about prepping it for install.





The install was complete once again by end of June 2016. The hole in the block was clear to see, there was a piece of conrod floating round in the sump, the bottom of the rod was still attached to the crank & the top was attached to the piston but had embedded itself under the skirt. So basically full on snapped a rod & part of it blew a hole in the block. I have the piston as an ornament now.












What a saga! Two K20's later and we're all good. Everything has been right as rain since then & I'm loving it again. Almost 2 years with this engine now & no sign of stopping! Even plucked up the courage to install an oil cooler again but this time with braided hoses. A lot of lessons learned from my first K, valuable lessons.

So that's the story from the last few years. Other than that I've done some other tweaks & mods over the time. Full spec list provided below for those who are interested. Good to be back :D

Here's some more photos to tell the story including when I resprayed the inside, fitted my LCA & tie bar and some track stuff.















Engine & Transmission
- K20A2 (the way Honda built it)
- NPQ3 Gearbox w/ MFactory Helical LSD & Carbon Synchros
- EP3/DC5 Drive Shafts
-Wire Tuck
- ACT Streetlite Flywheel
- ACT Stage 2 Street Clutch
- 3" Hybrid Racing K-swap Intake
- S90 3" throttle body
- RBC Inlet Manifold Ported 3"
-3" Solid Fabrications decat exhaust
- K-Tuned wiring conversion harness
- Hybrid Racing 4-2-1 manifold
- HASPORT K-Swap engine mounts 62A bushings EKK2
- K-Tuned race spec shifter cables
- K-Tuned no-cut shifter box
- K-Tuned clutch line kit
- K-Tuned heater hose kit
- K-Tuned fuel line kit
- K-Tuned fuel rail
- K-Tuned fuel pressure regulator w/ gauge
- K-Tuned pulley kit
- Mishimoto K-swap radiator, fan & hoses
- PRB ECU running Hondata KPro
- Clockwise Motion Sump Baffle
-Setrab 19 Row Oil Cooler with Mishimoto Braided Lines

Suspension & Steering
- BC BR Series Coilovers
- Hardrace Drop Links
- DC2 subframe, forks, ARB & steering rack
- Karcepts KWH005 hubs w/ ARP extended lugs
- Power steering removed
- A/C removed
- BWR LCA & LTB

Brakes
- Stoptech Powerslot Grooved Disks
- EBC Yellowstuff Pads
- Goodridge Braided Lines
- Castrol SRF Fluid

Wheels & Tyres
-OEM EK9 Enkei Wheels
-Bridgestone Potenza RE002
-Advan RG Track Wheels
-Federal RSR Semi Slicks

Interior
- Sparco Evo FIA Buckets
- Sabelt Harnesses
- Tegiwa Harness Bar
- Momo Steering Wheel
- Battery Relocate
- Stepper Motor Oil Temp & Pressure Gauges
 




Top