Starter...


Ghettomonster

Active Member
Joined
Jul 23, 2018
Messages
323
Car(s)
Honda Civic EJ9
Hi all

A couple of month back i mentioned that it was my main fuse that went pop...well infact i think its my starter motor!

Been using my car for a week now and it always sounds a bit sluggish on start. But last night when i was about to come home from the stables i had absolutely no power again. Here we gooo! So i swapped the fuse out for another new one still nothing.

I dont know if it was pot luck but i moved my gearstick back and forth then back into Park (auto) turned the key then all electrics come back on.

Drove home fine got home turned it off then went to turn it back on absolutely nothing again...so im assuming its the starter slowly dying.

Could anyone shed some light or experience that they may of had or if it could be anything else im missing?

My plan tonighy is short the starter and see if it fires up.

Cheers
 



Pete180

Lost in dreams..
Joined
Apr 13, 2012
Messages
1,465
Car(s)
EM1 Coupe
Nevermind all...it was me being a tit the battery cable was a tiny bit slack. Dogged it up fired up like a dream!

All happy again!!
Glad its sorted mate. Make sure the terminals are clean yh, none of that gunky stuff or limescale whatever it is, good stuff :)
 


Ghettomonster

Active Member
Joined
Jul 23, 2018
Messages
323
Car(s)
Honda Civic EJ9
Glad its sorted mate. Make sure the terminals are clean yh, none of that gunky stuff or limescale whatever it is, good stuff :)
Yeah i had bother with that stuff on my GF L200.

Cheers mate my starter doesnt sound sluggish now because i thought it might of been that.
 


Top