B16a2 Hesitating/Bogging

Discussion in 'Engine' started by Dunne3CC, Mar 15, 2016.


  1. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Converted my Ej6 to B16a2 and I am suffering with a bad hesitation issue. Most noticeable at lower rpm but continues throughout the rev range. Car just feels as if im in too high of a gear all the time. Here is a list of what ive changed so far. Car is running a sir p30 ecu with a jumper harness. Compression tested a stable 195psi across all 4pots and is not using coolant. Timing perfect and ignition timing set to 16degree BTDC

    Fuel Pump
    Fuel Filter
    Injectors
    Fuel Pressure Regulator
    Lambda
    Dizzy
    Plugs
    Leads
    ECU
    TPS
    MAP
    Earths

    Im running out of options as you can see. Can a bad knock sensor cause bogging without throwing a CEL? Other than the knock im think bad Intake Air Temp Sensor or bad quality jumper harness. Any help on this would be great.
     

  2. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    I'm having the same problem only thing I haven't changed is the fpr and the ecu I'm out of ideas
     
  3. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    Does it only happen when it's warm
     
  4. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Its alot more noticeable when its warm
     
  5. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Have you tried knock sensor?
     
  6. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    No not yet
     
  7. LiamEk9

    LiamEk9 Active Member

    Joined:
    Nov 3, 2014
    Messages:
    199
    Likes Received:
    57
    Location:
    North Lincolnshire
    I've got a bogging issue on my B16 that I threw in my Ek9 for a track day. I'm putting it down to the spark plugs being the wrong grade and the coil in the dizzy being a bit pants, but I will let you know when I get round to changing them.
     
  8. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    I changed the plugs and coil no different
     
  9. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Im going to try knock sensor next
     
    ruprecht likes this.
  10. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    Let me know if it works I'm going to get the valves adjusted
     
  11. MiRaGe

    MiRaGe Member

    Joined:
    Aug 22, 2008
    Messages:
    66
    Likes Received:
    5
    Location:
    England
    fuel filter isn't in front of the pump is it?
    (assuming its an inline pump)
     
  12. robthedoc

    robthedoc civic disobedience

    Joined:
    Feb 14, 2013
    Messages:
    1,534
    Likes Received:
    864
    Location:
    Edinburgh
    Just a thought, the jdm ecu will be fuelling for different cams? b16a? Also to test your jumper harness have the car running and shake the ecu to move all the wires (ecu un mounted) if theres bad wires in the jumper the running of the engine will likely be effected.

    Finally when you changed your tps did you set the voltage for closed and WOT?
     
  13. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Fuel filter is in the bay it was changed. Yeah its a different map but not extreme to the point of causing severe hesitation. No difference really in the running when I move the ecu around unfortunately. Yeah set to 0.5 closed and 4.5 WOT. Bought a knock sensor last night should have it friday.
     
  14. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    Done my knock sensor today no different still same problem as you
     
  15. Lee91

    Lee91 Member

    Joined:
    Mar 9, 2014
    Messages:
    90
    Likes Received:
    25
    Location:
    Ireland
    It's not throwing any codes up is it? Try another dizzy that you know is good, like off a friends car or something and see if it's the same.
     
  16. HUM22A

    HUM22A Member

    Joined:
    Aug 14, 2009
    Messages:
    67
    Likes Received:
    6
    Location:
    Glasgow
    Check tps and map sensor plugs are plugged into right sensors. They can plugged into each other as it's same plug.
     
  17. Dunne3CC

    Dunne3CC New Member

    Joined:
    Mar 7, 2016
    Messages:
    17
    Likes Received:
    6
    Location:
    Osaka
    Tried knock sensor and thought it helped a bit but back to square one now. Done the inlet mani gasket too. Im going to try getting rid of my jumper harness next for a proper obd2b ecu but the fact that ruprechts is genuine ek4 and doing that same thing is making me think its a valve/headgasket issue now
     
  18. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    Hope not
     
  19. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    I'm thinking throttle body
     
  20. ruprecht

    ruprecht Active Member

    Joined:
    Jul 8, 2010
    Messages:
    248
    Likes Received:
    35
    I done some research and it's saying that it can be down to the tps so I'm going to go over mine again and go through the whole process again
     
    Dunne3CC likes this.

Share This Page