Car dies and won't start randomly

Discussion in 'Forced Induction' started by sLeEpY, Aug 18, 2017.

  1. sLeEpY

    sLeEpY New Member

    Joined:
    Apr 20, 2012
    Messages:
    12
    Likes Received:
    0
    Location:
    Jordan
    Hi There,

    I have a turbo charged b16b with hondata s300 v3, most of the mechanical parts upgraded such as fuel pump, fuel pressure regulator, injectors, map sensor, air intake, clutch, spark plugs, etc... while keeping the engine stock (internals). it produced 250 whp on a Mustang dyno.

    The car is a daily driver and while I am driving no matter the time or the place or the temperature, the car suddenly dies, sometimes I just lose the feeling of the gas pedal, other times it just chokes then it continuous running normally, or chokes then dies, it never happened while am on WOT, and I hope it doesn't cause I guess it is going to cause a mess.

    And when it dies, it just won't start, as if, I turn the switch on, it starts, then immediately stops (dies again), so nothing is wrong with the switch or ignition, cause even if I keep the key on the ignition position it will die and I will hear the ignition sound as well.

    But after leaving the car for like 10 mins, it starts fine and runs fine (not a heat problem cause it happened first thing in the morning right after starting it for like 30 seconds)

    I started with replacing the fuel pump, that was the first guess by my mechanic, and at the same time I replaced the fuel filter, and spark plugs, then it ran fine for 4 days with no issues at all then it happened again.

    This time I changed the ignition coil in the distributor, our second guess, then it ran fine for the same 4 days with no issued then it happened again.

    I also replaced the coolant sensor in the 3rd week, and guess wt, it ran fine for 4 days with no issues at all and then it happened again.

    What to check next? fuel regulator? fuel rail? spark plug wires?

    The issue is it happens randomly and I am unable to get someone to check it while the issue is there, so we are just guessing based on the symptoms.

    Appreciate your help guys, I have paid a considerable amount of money for what seems to be noting, so far!

    Cheers.
    Moe
     
  2. harvey j

    harvey j PSN: DIRTY-JDM-B20

    Joined:
    Mar 15, 2011
    Messages:
    673
    Likes Received:
    38
    Location:
    london borough of Havering
    Have you tried injectors? What make are They? Are they wired in good or using piggy back connectors.

    Also check your voltage and when it dies and won't start check your plugs see if they are covered in fuel, it sounds like it's flooding out, if my voltage drops below 10.7v my car won't start with my id1000's , injectors are normally always open and use voltage to close them
     
  3. sLeEpY

    sLeEpY New Member

    Joined:
    Apr 20, 2012
    Messages:
    12
    Likes Received:
    0
    Location:
    Jordan
    I didn't check the injectors yet, and they are grams 500cc, and their wiring is good! And for the voltage, I monitor it using the hondata app on the phone and its fine, 13-14 while running, didn't check it when it dies cause there is not enough time to see when connected using bluetooth! But will check it.

    Update: last Saturday I changed the board that gives the signal to the fuel pump and the engine (I dont know its name sadly) it is the one located between the passenger seat door and the glovebox, and now the check engine light comes up with a drop in rpm and the car chokes without dying, for a couple of times then it died, and the symptoms are now different since it wont start and die the way it used to, but it wont start at all! And the check engine light didnt show up before!

    I guess its the injectors, do u agree given these updates?
     

Share This Page